Slow Performance
Incident Report for Zeavo
Resolved
This incident has been resolved.
Posted Apr 05, 2019 - 08:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2019 - 16:13 UTC
Investigating
We are currently investigating reports for slow performance of DebtKit.
Posted Apr 04, 2019 - 14:36 UTC
This incident affected: DebtKit App.