Inbound Email Issues
Incident Report for Zeavo
Resolved
We have received confirmation from our provider that this issue has now been resolved.
Posted 8 months ago. Feb 06, 2019 - 11:06 UTC
Identified
A provider issue has been identified that is affecting the delivery of inbound email. Our provider has identified the issue and a fix is being implemented.

We're monitoring the situation closely and will provide further updates here.
Posted 8 months ago. Feb 05, 2019 - 10:58 UTC
This incident affected: DebtKit App.